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CONVERSIÓN DE PÍXELES A MICRAS PARA CÁMARA OPTIKA BV9 

1- ELEGIR LA RESOLUCIÓN ADECUADA (1280x960 O 800x600) EN EL PROGRAMA DE LA CÁMARA. 
2- ASEGURARSE QUE LA RESOLUCIÓN Y LA CALIBRACIÓN EN EL PROGRAMA DE LA CÁMARA SON LOS CORRECTOS 

ANTES DE ADQUIRIR LA IMAGEN. 
3- USAR EL TAMAÑO DE LA IMAGEN Y EL OBJETIVO EN EL PROGRAMA DE ANALISIS DE IMAGEN “IMAGEJ” PARA 

CALIBRAR LAS MICRAS CORRESPONDIENTES. 

TAMAÑO DE LA 
IMAGEN OBJETIVO MICRAS 

1280x960 

ROJO 1430 

AMARILLO 550 

VERDE 280 

AZUL 111 

800x600 

ROJO 1643 

AMARILLO 673 

VERDE 343 

AZUL 135 

CODIGO ASCII MICRAS = ALT 230 



USANDO EL PROGRAMA IMAGE J 

OPERACIONES BÁSICAS. BARRA DEL MENÚ (NO ICONOS) 

En submenú FILE nos encontraremos las operaciones básicas a realizar con el archivo de imagen que se vaya a tratar. 
Las más importantes serán: OPEN, OPEN SAMPLES (ejemplos del programa), IMPORT, REVERT (revertir a la imagen 
original cuando el comando UNDO no es suficiente), SAVE (guardar) y SAVE AS (guarda en distintos tipos de archivos). 

En el submenú EDIT nos encontraremos algunas de las operaciones de tratamiento que se podrán realizar sobre la 
imagen. Las más habituales serán: UNDO (sólo la última operación, y en algunos casos en el que la imagen ha sido muy 
tratada es imposible revertir completamente. En estos casos es mejor emplear el comando REVERT), CUT, COPY, 
PASTE, CLEAR, FILL (muy útil en el caso que se quieran rellenar áreas de la imagen para que no interfieran), INVERT 
(invierte los colores de la imagen). En OPTIONS están las configuraciones de las herramientas que aparecen en forma 
de iconos por defecto dentro del programa: ROUNDED RECT TOOL, WAND TOOL, ARROW TOOL, PROFILE PLOT 
OPTION, etc. 



    

IMAGE: Es uno de los submenús que más se empleará en el tratamiento de las imágenes para su análisis. Se encuentra 
el comando TYPE (donde se puede convertir la imagen en función de los bits), ADJUST (donde se pueden ajustar los 
niveles de brillo y contraste, y donde se encuentra THRESHOLD que se empleará para resaltar las áreas de análisis), y 
finalmente TRANSFORM (donde se puede transformar una imagen a sus datos numéricos). 

    

    

Otro de los submenús más importantes es el de PROCESS, donde se encontrarán comandos como: SMOOTH (suavizar 
la imagen, con desenfoque), SHARPEN (aumentará la nitidez y el contraste de la imagen, lo contrario a SMOOTH), FIND 
EDGES (comando para detectar los bordes cuando se quieren hacer medidas sobre zonas muy concretas cercanas al 
borde, por ejemplo forma de la una partícula), ENHANCE CONTRAST (mejora automática del contraste). Otro de los 
comandos más importantes es el de BINARY (este comando se suele usar con asiduidad para preparar una imagen 
antes de su análisis y pasarla a blanco y negro).  



    

    

El submenú ANALYZE es uno de los más importantes puesto que en él se encontrarán los comandos para poder realizar 
el análisis de imagen y obtener los resultados a partir de ella. MEASURE (medida de la imagen activa, por defecto mide 
la imagen sin diferenciar nada dentro de ella), ANALIZE PARTICLES (por defecto mide aleatoriamente en función de la 
última operación realizada), SUMMARIZE, DISTRIBUCIÓN (son las ventanas que aparecerán con los datos 
analizados).SET MEASUREMENT (en el podremos elegir las magnitudes a medir: área, esfericidad, compacidad, 
redondez, diámetro feret, etc.). SET SCALE (se emplea para calibrar la imagen que se ha tomado, por ejemplo pasar 
de píxeles a micras, cm, mm, etc., es decir, unidades de medida. Para lo cual es necesario saber a cuántos píxeles 
corresponde la unidad de longitud elegida). 

    



    

CALIBRATE (se usa cuando es necesario calibrar la escala de grises de la imagen. Es una operación muy complicada que 
no se suele hacer, es preferible trabajar sobre una buena imagen). HISTOGRAM (es la distribución de frecuencias de 
colores de la imagen que esté en uso). PLOT PROFILE (traza el gráfico de distribución de colores – en escala de grises 
– de la línea o sección que resaltemos, es un perfil colorimétrico. Si se pulsa en la parte inferior del gráfico “LIVE” se 
actualizará el perfil colorimétrico según movamos la línea. Según el grosor de la línea tendremos la media de los valores 
dados por ese grosor. También se emplea para áreas. Los resultados se pueden salvar como una hoja Excel). SURFACE 
PLOT (traza un perfil en un área determinada, para lo cual es necesario pasar a escala de grises 8 bits) 

    

    

En el submenú de TOOLS se pueden encontrar comandos como: SAVE XY COORDINATES, FRACTAL BOX COUNT, 
ANALYZE LINE GRAPH, CURVE FITTING, ROI MANAGER (para la selección de áreas), como más interesantes y que se 
emplean habitualmente SCALE BAR (utilidad que se emplea para poner la leyenda del tamaño de la micrografía. En 
este caso es necesario haber empleado SET SCALE para tener calibrada la imagen antes de poner la leyenda).  



    

En el submenú de PLUGINS, se encuentran ubicados los comandos: MACROS (donde se pueden instalar macros 
concretas para determinados usos, programar macros específicas, etc.), SHORTCUTS (teclas que sirve para agilizar el 
uso de comandos), UTILITIES (donde se puede encontrar CONTROL PANEL, y comandos relativos al propio programa), 
COMPILE Y RUN (una vez realizada la macro se debe compilar para poderla usar), INSTALL (en este comando se podrán 
instalar plugins, macros, o scripts).  

     

    

La parte más interesante en este submenú son los comandos 3D, donde se encuentra la herramienta INTERACTIVE 3D 
SURFACE PLOT (donde se simula la superficie en función de los valores de colorimetría). En ANALIZE están los 
comandos BATCH MEASURE (donde se puede aplicar un grupo de medidas sobre una carpeta de archivos siempre y 
cuando se puedan aplicar las mismas condiciones. No es conveniente para microestructuras complejas), CELL 
COUNTER (puede contar partículas y fases de formas determinadas, inicialmente hay que definirlas), EXAMPLES, 
FILTERS, GRAPHICS, INPUT-OUTPUT (específico para distintas áreas de conocimiento), PROCESS, etc. Interesante es el 
comando QUANT-CT en su herramienta PHASE QUANT (opera como un pequeño programa dentro de la aplicación 
principal). Por último, en TOOLS se encuentra la herramienta de LINE PROFILE TOOL (que realiza un barrido de línea 
dentro de la imagen). 



   

    

    

    



    

 

    

    

El submenú de WINDOWS configura el interface de la aplicación, y el submenú HELP presenta ayuda en cuanto a 
instalación, documentación, recursos variados y actualización en línea. 



    

EJEMPLOS 

Microscopía Óptica de Polvo  

1) Calibración de la imagen: Emplear el comando SET SCALE en Analyse>Set Scale. 
2) Colocar el tamaño de la imagen en píxeles y la distancia conocida determinada por la calibración del programa 

de adquisición de la cámara del microscopio. Ejemplo: 1280 pixeles, objetivo verde corresponde a 280 micras 
(µ) y unidades micras (µ) [mantener pulsado Alt tecleando 230]. 

3) Comprobar que en la parte superior de la imagen aparece la calibración en micras (µ) [280x210 µ (1280x960)] 

…

 

4) Poner etiqueta o leyenda correspondiente a micras en las micrografías, seleccionar SCALE BAR. Siempre es 
conveniente hacer una copia de la imagen para poner la etiqueta de las dimensiones (micras). En este caso 
podremos guardarla, pero no trabajar sobre ella puesto que la etiqueta interferirá sobre las medidas. 

    



5) Guardar la nueva imagen en otro formato usando el comando SAVE AS…. El más común para posteriormente 
imprimir es el .jpg o .jpeg, dando una buena calidad de imagen para un menor tamaño de archivo. Si no 
queremos perder información podemos grabarlo en otros tipo de archivo como pueden ser .tiff, .bmp, .png, 
etc. Incluso se puede grabar como datos de texto (.txt) en el caso que queramos posteriormente extraer datos 
numéricos de la imagen para tratarla con un programa como el Excel (usuarios avanzados). 

 

6) Mejora de las imágenes para su tratamiento posterior. En muchos casos es preferible tener una mayor nitidez 
o que las distintas fases estén más contrastadas. Para mejorar las imágenes como mínimo habrá que aplicar 
distintos filtros para poder mejorarla. Los comandos más empleados son Sharpen y Enhance Contrast. 

    

7) En algunos casos, y para aplicar algún comando o herramienta, se tendrá que trabajar sobre una imagen en 
escala de grises (8 bits) o en blanco y negro (binario). Para ello se emplearán los comandos de Escala de Grises 
8-BIT (Image>Type>8-bit) o de Binarizar Make Binary (Process>Binary> Make Binary). Siempre es conveniente 
aplicar los comandos de mejora de imagen (anteriormente descritos) antes de aplicar cualquiera de estas dos 
operaciones. 

    



    

8) Una alternativa para mejorar las condiciones de una imagen es usar el comando Brightness/Contrast. Aunque 
se puede emplear el comando automático Enhance Contrast, en determinadas ocasiones es mejor ajustar el 
brillo y el contraste de forma manual. Para esto se empleará el comando Brightness/Contrast (Image>Adjunt> 
Brightness/Contrast) 

    

9) En ocasiones, poder operar sobre una imagen es complicado debido a que las fases/partículas están 
acumuladas o aglomeradas y se hace difícil su conteo para sacar datos. Existen filtros que pueden ayudar a 
solucionar este problema: Erode, Dilate, Open, Close, Outline, Skeletonize, etc. Estas operaciones se 
encuentran en Process>Binary. La mayoría de ellas necesitan que se mejore y binarice la imagen original. 

BINARY ERODE DILATE 

   
OUTLINE FILL HOLES SKELETONIZE 

   
 



 

10) Para caracterizar manualmente una imagen cuyo tratamiento no permite analizarla de forma automática se 

puede emplear el comando Wand Tool (Varita). Si se pincha dos veces sobre el icono  de la barra de 
herramientas podemos ajustar la tolerancia del comando. Con este comando es posible seleccionar áreas 
determinadas graduando la tolerancia que deseemos para que se adapte mejor a la forma. Pulsando 
simultaneamente la tecla “↑” se pueden añadir áreas seleccionadas si queremos medir el global. 

    

11) La herramienta Wand tool también se puede emplear en escala de grises y en este caso aparecerá una segunda 
opción dentro de la ventana de Tolerancia, Enable Thresholding que se puede seleccionar y aparecerá una 
capa sobrepuesta sobre la imagen (de color rojo). Si se quieren medir partículas aisladas no es conveniente 
esta operación, si es posible y el contraste es adecuado, es mejor operar sobre la imagen original. Con la 
operación de Thresholding se puede ajustar la capa creada sobre la imagen. La operación de Enable 
Thresholding sólo es conveniente si el usuario es experto. 

     

    
12)  Para el conteo de partículas de una microfotografía de forma manual es conveniente familiarizarse con el 

comando Wand tool. Aunque el conteo manual es algo laborioso, si se quieren tener datos a partir de 
imágenes complejas es un método sencillo. Lo conveniente es hacerse con un amplio muestreo (más de 50 
medidas) sobre distintas imágenes para poder realizar después un estudio representativo. Ejemplo: conteo de 



partículas retenidas en tamiz de 20 micras. Se observa que muchas de las partículas están aglomeradas debido 
a una mala dispersión, aun así es posible contar partículas si se han tomado diferentes imágenes. La elección 
de los parámetros que se analizarán de cada partícula aparecen en SET MEASUREMENT. Si se activa Add to 
overlay las partículas que se vayan midiendo se irán señalando. Para ir midiendo se señala la partícula con el 
Wand tool e inmediatamente se selecciona MEASURE (Analyze> Measure) de esta forma según se vayan 
tomando los datos se irán integrando dentro de una tabla de valores que posteriormente se puede exportar 
a Excel para trabajar con ellos. 

       

    

    

    



Aparte del comando de Wand Tool se puede emplear también el Freehand Selections  en la misma operación y 
sobre la misma imagen. De ese modo aquellas partículas que no se pueden diferenciar con el Wand Tool se pueden 
seleccionar a mano. Se opera de la misma forma, cada vez que se señale una partícula se selecciona MEASURE. 

    

       

En el ejemplo se observa como algunas partículas se han señalado a mano mediante el Freehand Selections, sólo las 
más evidentes. Para comprobar si está siendo correcto el análisis se puede hacer la gráfica de una distribución de 
Gauss, para ver si se va aproximando a una campana de Gauss o distribución natural. Se observa que aunque no 
cumple completamente se va acercando (la distribución realizada sólo con el Wand tool no se acercaba a la forma 
acampanada). Al aumentar el número de resultados juntando los datos de distintas imágenes se puede conseguir un 
buen análisis de las características de las partículas. 

Microscopía Óptica de Fases del Polímero  

1) Calibración de la imagen en micras (µ) [550x412,5 µ (1280x960) aparece en la imagen calibrada][Nota: La 
imagen siempre se debe calibrar antes de empezar a medir, pero para hacer mejoras en la imagen no es 
necesario calibrarla dimensionalmente, en todo caso si se quiere calibrar en cuanto a color (usuario experto)]. 

2) Mejorar la imagen si es posible, aplicar los filtros de Sharpen, Enhance Contrast, etc. 
3) Determinar el mejor método para medir, porque se pueden emplear varias opciones. La imagen puede tener 

ralladuras que ha sido muy difícil eliminar. El método más sencillo para este tipo de imagen pasar a 8-bit 
(Image>Type>8-bit) y despues binarizar Make Binary (Analysis>Binary) y a partir de ese momento emplear los 
comandos de Erode, Dilate, Open, Close, etc. Primero probaremos con ellos, teniendo cuidado de emplear de 
uno en uno para poder aplicar UNDO (Edit>Undo) cuando sea necesario. En el ejemplo se emplea el comando 
Fill Holes (Analysis>Binary>Fill Holes) 



    

[Nota: Se puede emplear herramientas de Dibujo para mejorar la imagen en el caso que sea necesario previamente a 

la operación de Fill Holes  . En el ejemplo para evitar que se junten varias áreas de la imagen debido a los 

arañazos. Pinchando dos veces sobre el icono del Pincel Brush se puede elegir el color que deseemos, en este caso 
el idóneo sería negro, así como el grosor] 

Resultado Fill Holes sin Pincel           Pincel previo a Fill Holes  Resultado Pincel+Fill Holes 

   

4) Si sólo vamos a analizar partículas empleando el modo manual no es necesario porque podemos medir las 
áreas que estén mejor definidas y podemos hacer el mismo tratamiento para varias imágenes que se 
emplearán para obtener un resultado global del material. 

5) Aplicación del Threshold para diferenciar los porcentajes aproximados de ambas fases. En el ejemplo, sin 
emplear el Pincel para separar las áreas conectadas, da un valor de 48,49% de fase esférica.  

    

En el caso de haber retocado con el pincel el resultado es de 46,71% de fase esférica. El error entre ambos métodos 
es inferior al 10%, pero es alto si sólo se mide sobre una sola imagen. 

6) Se podrán seguir empleando los comandos de Erode, Dilate, etc., si así lo consideramos necesario. No 
obstante, hay que tener en cuenta que variarán los valores del porcentaje de fases. En ese sentido, es mejor 
realizar cualquier operación que afecte a la medida antes. 

Pincel + Rellenar huecos (Fill Holes) Erosión (Erode) posterior 



    
 

7) Comenzaremos a medir las áreas esféricas con la herramienta Wand Tool. Aplicaremos el método 
anteriormente descrito, alternando sucesivamente selección con medida. Ajustaremos la herramienta en 
función de la tolerancia. De este modo tendremos al final una tabla de resultados. Previamente deberemos 
haber elegido en Set Measurements los parámetros que deseemos para caracterizar la fase. 

    

    

8) Se puede elegir ver Summarize (Analysis>Summarize) y Distribution (Analysis >Distribution). Cuando se 
selecciona Summarize en la tabla de resultados aparecerá la Media (Mean), SD (Standart Deviation – 
Desviación Estándar), Mínimo y Máximo. En Distribution, dependiendo de la variable que elijamos nos saldrán 
unas representaciones. Ejemplo: Elegimos Round (Redondez como factor de forma), cuanto más cercano a 1 
la forma es más redonda, cuando más cercana a 0 más irregular. Viendo la microestructura la mayoría de las 
partículas estarán cercanas a 1. En la opción List (dentro de la ventana en la que aparece el gráfico) se puede 
exportar a Excel para ser representada con el estilo que se prefiera. Los resultados también se pueden exportar 
a una tabla Excel [Nota: cuidado con los puntos (Inglés) que dependiendo de la configuración del Excel, a veces 
no los transforma a coma (España)] 



    

    

 

         

 



Microscopía Óptica de Fases en la mezcla Caolín-Residuos  

1) Calibración de la imagen en micras (µ) [1430x1072,5µ (1280x960) aparece en la imagen calibrada][Nota: La 
imagen siempre se debe calibrar antes de empezar a medir, pero para hacer mejoras en la imagen no es 
necesario calibrarla dimensionalmente, en todo caso si se quiere calibrar en cuanto a color (usuario experto)]. 

2) Mejorar la imagen si es posible, aplicar los filtros de Sharpen, Enhance Contrast, etc. 
3) Pasar la imagen a 8-bit (Image>Type>8-Bit) en escala de grises. 

    

    

4) Mediante el Threshold ajustamos el área ocupada por las fases blancas. Por defecto sale un valor de 12,29% 
de fases blancas. Si movemos el cursor ajustamos el borde de las fases a un valor del 18,65%. Hay bastabte 
diferencia entre ambas medidas, para minimizar el error se deben hacer medidas sobre distintas fotos y sacar 
la media de los valores. 

    

 

 

 



5) Podemos optar por binarizar, Binary, la imagen en vez de analizar en escala de grises. De esta forma podemos 
comprobar cuál de los dos métodos es el más adecuado. Después de binarizar optamos por usar Fill Holes 
(rellenar huecos). Se aplica Threshold y en este caso vemos que el área ocupada por la fases blancas es 13,08%, 
un valor intermedio a los calculados anteriormente y más próximo al que salía por defecto en escala de grises. 

...  

 

6) Una vez ajustada, se procede a realizar la medida automática de las áreas blancas, puesto que la imagen ha 
quedado bien definida. Se elige Analize Particles y se selecciona Exclude on edges para evitar que las áreas 
queden cortadas en los límites de la imagen e Include Holes para evitar posible fallos en la preparación 
metalográfica. 

    

7) Se selecciona Summarize para tener los valores medios y globales en la tabla de resultados.  
8) Se graban las distintas tablas de resultados generadas en formato Excel para ser tratadas con este programa. 

Si se pulsa Flatten (F) se puede obtener una imagen con las etiquetas y las áreas medidas. 



 

 

 

 

 

 

 

 

Microscopía Óptica de Fases en la mezcla Caolin-Residuos 1150ºC 



1) Calibración de la imagen en micras (µ) [550x412,5µ (1280x960) aparece en la imagen calibrada]
2) Mejorar la imagen si es posible, aplicar los filtros de Sharpen, Enhance Contrast, etc. En este caso en concreto

es mejor ajustarla manualmente con Adjust (Image>Adjust>Brightness/Contrast). Se distinguen claramente 3
fases a mayores aumentos.

3) Pasar la imagen a 8-bit (Image>Type>8-Bit) en escala de grises.
4) Para calcular los porcentajes relativos de las fases es necesario ajustar individualmente cada una de ellas. Se

empezará por la más blanca (cromáticamente está cerca del mayor valor 223-255, 223 ajuste más fino que el
inicial 216). Seleccionaremos Analyze Particles en (Analyze>Analyze Particles) y se realizará el conteo
automático. Finalmente se seleccionara Summarize y se grabarán los resultados como una hoja Excel.

5) Se proseguirá por la que posee un color gris claro (cromáticamente está cerca del mayor valor 72-223
aproximadamente). Seleccionaremos Analyze Particles y finalmente Summarize para dar por terminada la
obtención de datos de esta fase.



 

6) Se finalizará analizando la fase de color más oscuro (cromáticamente tiene los valores más bajos y cercanos a 
0 o negro). Seleccionaremos Analyze Particles y finalmente Summarize para dar por terminada la obtención 
de datos de esta fase. [Nota: es conveniente anotar los valores límites de las fases para que no solapen o 
queden franjas de color sin analizar].  

 

Trazado de un perfil colorimétrico 

1) En este caso simplemente se emplea el comando de Line Profile  se elige una zona representativa de la 
imagen y se traza una línea. Simultáneamente junto con la línea aparece el perfil colorimétrico. Es una buena 
herramienta para determinar espesores, pistas de desgaste, gradientes de concentración, etc. 

 

Detección de fases cuando no son fácilmente reconocibles 



1) Se puede intuir la existencia en función de los valores cromáticos de la imagen. Lo más habitual es emplear 

microscopía electrónica para determinarlas y cuantificarlas. El comando Lookup Tablas Action Tool , 
permite cambiar valores de saturación, tonos, etc. para identificar las posibles fases que pudiesen existir.  

2) Después de realizar la mejora de la imagen y la transformación a escala de grises se puede emplear esta 
herramienta. Se pulsa repetidamente sobre el icono hasta encontrar la imagen o imágenes que más 
diferencien las fases que puedan existir. 
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